Page MenuHomePhabricator

Eventhandler hotfix for 3CB 60mm mortar showing wrong range tables
Closed, Resolved (Pending)Public

Description

The 3CB M6 60mm mortar has built-in range tables that are always calculated using air friction as long as ACE is loaded, however, it appears that air friction is not applied to the shells.

The following eventhandler forces the frictionless range table to be shown (it has to be an eventhandler and a delay because the friction/no friction evaluation is made every time a player enters the mortar).

eh = player addEventHandler ["GetInMan", {
	params ["_unit", "_role", "_vehicle", "_turret"];
	if (_unit == player && _vehicle isKindOf "UK3CB_BAF_Static_M6") then {
		[{_this # 0 setVariable ["UK3CB_ACE_Ballistics", false]}, [_unit], 0.5] call CBA_fnc_waitAndExecute;
	};
}];

Event Timeline

confirmed laser accurate with this or the printed tables. just need to implement it for stratop now :)

Should be all done now!
Might be worth reporting that issue to uk3cb tho.

Keithen closed this task as Resolved (Pending).Feb 9 2020, 12:49 PM
Keithen claimed this task.
Keithen removed Keithen as the assignee of this task.