Page MenuHomePhabricator

BSU showing unable to load URL when the server is online
Closed, ResolvedPublic

Description

When trying to load the URL "http://u.beowulfso.com/synctest/server.json" in BSU it throws the error:

Error

Failed to load server file. Check the URL and try again.

OK

Details

Commits
Restricted Diffusion Commit

Event Timeline

Arron17 created this task.Jan 18 2017, 10:20 PM

After looking in to the loading of the URL with wireshark it loads up the file into BSU correctly:

No. Time Source Destination Protocol Length Info

9767 96.330588      192.168.0.16          51.255.142.184        HTTP     139    GET /synctest/server.json HTTP/1.1

Frame 9767: 139 bytes on wire (1112 bits), 139 bytes captured (1112 bits) on interface 0
Ethernet II, Src: Giga-Byt_ec:d8:9d (50:e5:49:ec:d8:9d), Dst: ArrisGro_12:4f:70 (c0:05:c2:12:4f:70)
Internet Protocol Version 4, Src: 192.168.0.16, Dst: 51.255.142.184
Transmission Control Protocol, Src Port: 50062, Dst Port: 80, Seq: 1, Ack: 1, Len: 85
Hypertext Transfer Protocol

GET /synctest/server.json HTTP/1.1\r\n
Host: u.beowulfso.com\r\n
Connection: Keep-Alive\r\n
\r\n
[Full request URI: http://u.beowulfso.com/synctest/server.json]
[HTTP request 1/1]
[Response in frame: 9770]

No. Time Source Destination Protocol Length Info

9769 96.363143      51.255.142.184        192.168.0.16          TCP      60     80→50062 [ACK] Seq=1 Ack=86 Win=29312 Len=0

Frame 9769: 60 bytes on wire (480 bits), 60 bytes captured (480 bits) on interface 0
Ethernet II, Src: ArrisGro_12:4f:70 (c0:05:c2:12:4f:70), Dst: Giga-Byt_ec:d8:9d (50:e5:49:ec:d8:9d)
Internet Protocol Version 4, Src: 51.255.142.184, Dst: 192.168.0.16
Transmission Control Protocol, Src Port: 80, Dst Port: 50062, Seq: 1, Ack: 86, Len: 0

No. Time Source Destination Protocol Length Info

9770 96.365156      51.255.142.184        192.168.0.16          HTTP     1230   HTTP/1.1 200 OK  (application/json)

Frame 9770: 1230 bytes on wire (9840 bits), 1230 bytes captured (9840 bits) on interface 0
Ethernet II, Src: ArrisGro_12:4f:70 (c0:05:c2:12:4f:70), Dst: Giga-Byt_ec:d8:9d (50:e5:49:ec:d8:9d)
Internet Protocol Version 4, Src: 51.255.142.184, Dst: 192.168.0.16
Transmission Control Protocol, Src Port: 80, Dst Port: 50062, Seq: 1, Ack: 86, Len: 1176
Hypertext Transfer Protocol

HTTP/1.1 200 OK\r\n
Date: Wed, 18 Jan 2017 20:04:40 GMT\r\n
Server: Apache/2.4.7 (Ubuntu)\r\n
Last-Modified: Fri, 06 Jan 2017 00:10:57 GMT\r\n
ETag: "375-54561da2966e3"\r\n
Accept-Ranges: bytes\r\n
Content-Length: 885\r\n
Keep-Alive: timeout=5, max=100\r\n
Connection: Keep-Alive\r\n
Content-Type: application/json\r\n
\r\n
[HTTP response 1/1]
[Time since request: 0.034568000 seconds]
[Request in frame: 9767]
File Data: 885 bytes

JavaScript Object Notation: application/json

Object
    Member Key: ServerName
        String value: Beowulf Strategic Operations
        Key: ServerName
    Member Key: ServerAddress
        String value: srv1.beowulfso.com
        Key: ServerAddress
    Member Key: ServerPort
        Number value: 0
        Key: ServerPort
    Member Key: Password
        String value: 
        Key: Password
    Member Key: CreationDate
        String value: 2017-01-05T22:49:49.293677+00:00
        Key: CreationDate
    Member Key: LastUpdateDate
        String value: 2017-01-05T22:49:49.314364+00:00
        Key: LastUpdateDate
    Member Key: SyncUris
        Array
            String value: http://u.beowulfso.com/synctest/
        Key: SyncUris
    Member Key: ServerGUID
        String value: bead8b83-4483-42c6-99e4-36de043af713
        Key: ServerGUID
    Member Key: ModFolders
        Array
            Object
                Member Key: ModName
                    String value: @BSOAddons
                    Key: ModName
            Object
                Member Key: ModName
                    String value: @BSOmaps
                    Key: ModName
            Object
                Member Key: ModName
                    String value: @CBA_A3
                    Key: ModName
            Object
                Member Key: ModName
                    String value: @CUP_Terrains_Core
                    Key: ModName
            Object
                Member Key: ModName
                    String value: @CUP_Terrains_Maps
                    Key: ModName
            Object
                Member Key: ModName
                    String value: @ProjectOPFOR
                    Key: ModName
            Object
                Member Key: ModName
                    String value: @RHSAFRF
                    Key: ModName
            Object
                Member Key: ModName
                    String value: @RHSGREF
                    Key: ModName
            Object
                Member Key: ModName
                    String value: @RHSUSAF
                    Key: ModName
            Object
                Member Key: ModName
                    String value: @ace
                    Key: ModName
            Object
                Member Key: ModName
                    String value: @acex
                    Key: ModName
            Object
                Member Key: ModName
                    String value: @acre2
                    Key: ModName
        Key: ModFolders

No. Time Source Destination Protocol Length Info

9776 96.415299      192.168.0.16          51.255.142.184        TCP      54     50062→80 [ACK] Seq=86 Ack=1177 Win=64512 Len=0

Frame 9776: 54 bytes on wire (432 bits), 54 bytes captured (432 bits) on interface 0
Ethernet II, Src: Giga-Byt_ec:d8:9d (50:e5:49:ec:d8:9d), Dst: ArrisGro_12:4f:70 (c0:05:c2:12:4f:70)
Internet Protocol Version 4, Src: 192.168.0.16, Dst: 51.255.142.184
Transmission Control Protocol, Src Port: 50062, Dst Port: 80, Seq: 86, Ack: 1177, Len: 0.

Debugged the application in visual studio and it is throwing an exception when trying to access the files:
An exception of type 'System.IO.IOException' occurred in mscorlib.dll but was not handled in user code

Additional information: The process cannot access the file 'C:\Games\ARMA MODS - Beowulf\@BSOAddons\addons\40th_backpack.pbo' because it is being used by another process

Confirmed this issue with both DEV and Release BSU and it looks as though the error only happens when Arma is open and therefore using the files that BSU is trying to access.

Arron17 updated the task description. (Show Details)Jan 18 2017, 11:09 PM
jsm added a comment.Jan 19 2017, 1:29 PM

Easy fix, I won't allow the user to run it if arma3 is open. Does raise some possible issues if this was ever used for non ArmA things.

Alternatively I could catch that exception and bail (if it happens on the first file its going to happen on every single file).

jsm raised the priority of this task from Normal to High.Jan 19 2017, 1:30 PM
jsm closed this task as Resolved by committing Restricted Diffusion Commit.Jan 19 2017, 6:52 PM
jsm added a commit: Restricted Diffusion Commit.